Trace Flag 3659


Many setup scripts for SQL Server include the 3659 trace flag, but I could not find official documentation that explains exactly what this flag means. After a lot of research, I found a reference to this flag in a script called AddSelfToSqlSysadmin, written by Ward Beattie, a developer  in the SQL Server product group at Microsoft.

The script contains a line which suggests that this flag enables logging all errors to errorlog during server startup. I’m unsure of what kind of errors are not logged without setting the flag, but I didn’t find any further reference. The BOL page for Trace Flags doesn’t list this one, so if you happen to know something more, feel free to add a comment here.

Archived WordPress comments (3)

Historical comments from the original site; this archive is read-only.

  1. newguise
    Thanks. I'm following instructions (to change server collation) which include this trace flag with no explanation as to why.

    Good to know what it does!
  2. Rick Bielawski
    This flag is, to the best of my knowledge, typically used when running SQL Server interactively to perform some type of maintenance that requires single user mode. By default not all possible messages are always logged. Especially informational messages. For example a message stating a given operation completed successfully may not appear. If you need to know when that operation finished (maybe so you can shut down and restart normally) you need to enable such messages with this flag.
    1. spaghettidba
      Thanks for the information! Very useful.

See also